Diesel Power
Mobile Icon BtnMobile Icon Btn RO
Newsletter

2006 LBZ Duramax/Edge wAttitude/Horrible Mileage

  
Diesel Power
Item Posts    Sort Order

2006 LBZ Duramax/Edge wAttitude/Horrible Mileage

 
shankster shankster
New User | Posts: 4 | Joined: 02/09
Posted: 02/18/09
11:55 PM

Hi there,  I'm new to the site so i'm hoping someone can help me!  I have an 2006 Duramax
Here's what done to it,
1, AFE Stage 2 Intake
2, MBRP 4" Exhaust Turbo Back
3, Edge with Attitude Chip
6" Lift with 20" rims and 35 Tires on it
I have been driving this truck for a cpl years and the mileage seems to be getting worse.  It now has 80k on it and thought it should be getting better but it is not!  I am averaging right around 300-350 km or 12 mpg with this thing and that is in the 5 setting on the chip which generally gave me the best milage before.  Other problems are when I tromp on it there is excessive black smoke and overboost reading of 31-33 psi.  I have the edge set at lowest smoke.  I just took the truck into the dealership with an oil sample and there saying that there appears to be no fuel in the oil but there does appear to be alot of carbon in my oil!  Has there ever been any reported problems with the edge chip?  Is there a different better chip that will give me all around performance and milage for this setup? The majority of the time this truck is a daily driver and 12 mpg is fairly un affordable I think!  Any suggestions or recomendation are muchly appreciated guys cause I am not sure where to go with this truck...besides sell it.  Thank's again and very nice site!!  JJ  

Richies Truck and Auto Richies Truck and Auto
Enthusiast | Posts: 355 | Joined: 05/08
Posted: 02/19/09
03:10 PM

Just curious, how long ago did you have the lift installed w the tires and what gears are you running? From my experience the dmax no matter what model, seems to get the best fuel mileage around 1800-1950 rpms cruising. If your curret gears are stock, the 3.73 w/the 6spd auto will put your cruising rpms @ 65mph somewhere in the 1500-1600rpm range. Way out of the power curve. This will also sacrifice low end causing black smoke due to loading down. 30-35 psi is not unusual for the LBZ to boost depending on altitude and temp. w/a module or programer. The carbon in your oil is no doubt from the excess fuel being injected and unburned (black smoke). It is definitely a bad thing! BTW dont sell it! The 06 LBZ/6spd is arguably the best version produced!  
Rich
05 GMC 3500HD CC/LB LLY
Fully built!
06 GMC 2500HD CC/SB LBZ:
Being built....
2011 3500HD H&S...
2013 Denali 3500HD H&S....

dmaxd2500 dmaxd2500
New User | Posts: 47 | Joined: 02/08
Posted: 02/19/09
08:57 PM

All very good points to consider from Richies. I'm curious, does your SES light ever come on? You may have a turbo/boost problem developing. I've never seen an LBZ turbo fail mechanically, but I have replaced vane position sensors and boost pressure sensors but you should be getting a warning light if something like that is going on. I have also seen EGR valves stick open or partially open, which causes a big internal air leak, and NOT set any codes at all, so you never know with these electronic systems. So like Richies said, you're either not operating the vehicle in it's optimal RPM range, or you're not getting the correct application of boost, I'm not so sure it's related to your Edge chip. I run my LBZ on level 5 to get the best mileage also, and by the way, don't sell it, I think it's probably the best Dmax version also, but you can't beat the mileage of an old LB7.  
2004 LB7 CCSB "ALFA"
Last Dyno Run-679.8/1186.0
youtube vids!  search xracer650

shankster shankster
New User | Posts: 4 | Joined: 02/09
Posted: 02/19/09
11:52 PM

Here probably a year ago I did get the egr valve changed out and it did help at the time?  So how do I know if there is something wrong with the turbo or maybe the sensor?  Again no codes so far but when I first put the chip in it would not overboost but now it does!  Never put that kind of black smoke out either unless I really wanted it to, and then it was only a nasty puff! All the codes that I can remember are fuel rail pressure to low and engine overboost at 33 psi and an egr code. You definately got a point about the gearing and the rpm as it is reving around 1600 rpm at 65mph.  For the injectors on these trucks, will they always have a code if there is something wrong with the injectors?  To give you an idea on how much smoke i can put out, If I'm on a long hill and have my cruise set at 65-70 mph it will blow solid black the whole way up if I do not switch the cruise off!  What I've done for now is take the chip out cause I've had it in at a dealer but again there saying there are no codes and nothing wrong with it which makes me wonder if there isn't something wrong with the chip.  I really appreciate the comments guys, the feedback so far has been great!  JJ  

Richies Truck and Auto Richies Truck and Auto
Enthusiast | Posts: 355 | Joined: 05/08
Posted: 02/20/09
02:29 PM

Couple more questions for you. How did you check the codes? Can you clear them and try again to give us the actual code numbers that are still there? I just want to make sure what the codes present are that you are getting and not some history codes. If you are getting more boost than normal, it kind of makes sense b/c you are over fueling, and fuel will build more boost. But you should not have any low rail pressure codes though unless a leak is present or restriction in flow? Do you have trouble starting the truck? If you disconnect the Edge does the trouble subside or continue the same? The edge may be experincing trouble commanding high rail press or long inj duration. It almost sounds like a cracked injector or malfunctioning pressure regulator on the cp3? See if your oil level is rising in the crankcase also.  
Rich
05 GMC 3500HD CC/LB LLY
Fully built!
06 GMC 2500HD CC/SB LBZ:
Being built....
2011 3500HD H&S...
2013 Denali 3500HD H&S....

BlackBetty06 BlackBetty06
New User | Posts: 44 | Joined: 10/08
Posted: 02/20/09
04:33 PM

Just my two cents. I read the entire online manual for the edge juice with attitude for the 06 LLY AND LBZ duramax engine. it mentions somewhere in the thing that an 06 LLY or LBZ will possibly get a low fuel rail pressure warning on level 5 and the hot file. Again just my $.02  

shankster shankster
New User | Posts: 4 | Joined: 02/09
Posted: 02/20/09
10:01 PM

I haven't really noticed any trouble starting the truck! Like I said before I have the chip out of it right now but haven't been driving it cause I'm in Kazahkstan! But coming home in 2 days..hooray All the codes that I described above were codes that actually set my engine light on when I was driving the truck, and then I just cleared them! The low rail pressure came on a few months ago and haven't seen it since!  I'm getting ready to take the truck on a long haulhere in another week, so I will pay close attention to it and get back to you guys!  If I had some cracked injectors would it bring up a code?...always?  I will pay close attention to it over the next couple weeks!  Really appreciate the help guys! JJ  

shankster shankster
New User | Posts: 4 | Joined: 02/09
Posted: 03/16/09
09:11 PM

Hello all!  I pulled the chip from the truck and put probly 300 or so miles on it so everything could relearn itself.  Took it on some long hauls and the mileage has actually gotten worse and is now around 10mpg!  I have taken it back to a dealer and they checked for codes and did a test on the injectors again and everthing tested fine...is what they told me.  I remembered they updated the ecm here a little bit ago so that the egr valve will cycle when the truck is shut off to knock any carbon off of it.  Next step is they are going to try and change the EGR valve under warranty again to see if that helps it.  I'm guessing it won't cause it didn't help the first time much...  The only other thing I can think of is the injectors?  The dealer says there is nothing wrong with them because there computer says everything is fine so yes i'm starting to get pretty frustrated.  Anybody have any other thoughts besides coming down to the States to get the truck fixed right???  Thanks for all your help!  JJ